Blog

Release Moodle 3.0.1 geschikt voor PHP 7.0

22 december 2015

Moodle 3.0.1 is een buitenbeentje in het release schema, want in januari komt versie 3.0.2. Het bijzondere aan 3.0.1 is dat deze Moodle versie draait op PHP 7.0. Dit is de nieuwste versie van het programmeertaal waarin Moodle is geschreven. Begin deze maand is PHP 7.0 gelanceerd en het grootste voordeel is de performance verbeteringen. Een Moodle site die draait op versie 3.0.1 en PHP 7.0 zal veel sneller ingeladen zijn en dat is positief. Zie hieronder ook de grafiekjes die Moodle zelf ter beschikking heeft gesteld. Bij het testen is een gewone Moodle cursus met het onderwerpcursusformat gebruikt met meer dan 100 activiteiten en bronnen.

PHP 7 compatibility makes Moodle faster

Let wel dat niet alle plugins gelijk ook werken met PHP 7.0. Want Moodle 2.9 geeft foutmeldingen met deze nieuwe PHP-versie, dus zeer grote kans dat de plugins ook errors gaan geven. Lees meer over Moodle en PHP7.
Naast de ondersteuning voor PHP 7.0 zijn ook enkele bugs opgelost (zie release notes).

De ontwikkelingen gaan dus de goede kant op, maar voordat alle Moodle sites en servers voorzien zijn van de nieuwste versie, zal nog wel even gaan duren.

 

Tags